Electric Golf Cart Refurb

Thread starter #1

paulito

Senior Member
New to the carting world but wanted a project to play around on with the boy. Have what i believe is a 94 Ezgo 36 volt junker. Put new set of batteries in her and she runs. However, at times it will shut off. Typical when you put the peddle to the floor. Was thinking it was the solenoid so i replaced that. The issue still remains. I can drive around 1/2 or 3/4 speed no problems but if it goes full out for a bit it tends to want to shut off. Let off the peddle and press again and off she goes. Any thoughts of where to start looking for probable culprits.

Again, new to this world and not looking to build a suped up off roading mud cart. just something plain jane simple for deer camp and around the hood. Thanks for any help.
 

Eudora

Senior Member
New to the carting world but wanted a project to play around on with the boy. Have what i believe is a 94 Ezgo 36 volt junker. Put new set of batteries in her and she runs. However, at times it will shut off. Typical when you put the peddle to the floor. Was thinking it was the solenoid so i replaced that. The issue still remains. I can drive around 1/2 or 3/4 speed no problems but if it goes full out for a bit it tends to want to shut off. Let off the peddle and press again and off she goes. Any thoughts of where to start looking for probable culprits.

Again, new to this world and not looking to build a suped up off roading mud cart. just something plain jane simple for deer camp and around the hood. Thanks for any help.
Waiting on a reply myself on this one. Family member with a '95 model having the same issue. Thanks
 
The copper wire wound up in your electric motor could be oxidized. That is not a good thing. Open up the motor and if the wire has a lot of green - buy a new motor!
 
Top