Trigger on Abolt

Thread starter #1
Need a lil advice guys. I bought a browning Abolt two yrs ago and after I shot it the first time I found something wierd acting about the trigger. After you shoot it and open and close the bolt it lets the firing pin down as you close the bolt. I can open the bolt back up and push the trigger forward and it's all good to go till you shoot it again. I dealt with it last yr but I swapped stocks and want to fix it. Could it be a broke spring or could it just be gummed up and need to be cleaned?
 
Timney makes a great trigger spring for the Abolt....very easy to do. I would try that and go from there. Your spring may be bad.

Last one I bought was around 40 bucks.
 
Thread starter #3
Timney makes a great trigger spring for the Abolt....very easy to do. I would try that and go from there. Your spring may be bad.

Last one I bought was around 40 bucks.
I took the trigger assembly of the receiver last night and got it soaking in some degreaser. It seems to have just been gummed up and wouldn't let it spring back to normal
 
I took the trigger assembly of the receiver last night and got it soaking in some degreaser. It seems to have just been gummed up and wouldn't let it spring back to normal
Awesome...the trigger kit makes a big difference. It comes with a 2 # and a 4# weight I believe.
 
Thread starter #5
Oh yeah I bought one last yr. I kept the light one and gave my brother the other. I came in this afternoon and washed it out and put it in the oven to dry good and it works fine now
 
Top